Max Upload Size

hullman56
@hullman56
last year
4 posts
On installing Gensosis it has recognised my server's Max Upload size as 1MB when it is actually 1GB. The Max Upload on the Genosis Qouta Config Page only shows 1MB, the system will not let me load anything larger, especially my 24.8Mb gedcom file.

Is there anyway I can change this setting under the hood, if so how do I go about it.

Thanks in advance.
updated by @hullman56: 02 Oct 2020 12:28:12PM
douglas
@douglas
last year
2,691 posts
Hello,

If you can't go to Admin > Core > System Core > Quota Config and change the max upload size in the drop-down selection, then you'll want to contact your hosting provider and have them change your php.ini settings for the following:

post_max_size
upload_max_filesize
memory_limit

Hope this helps!


--

Douglas Hackney
Jamroom Team - Designer/Developer/Support
FAQ-Docs-Help Videos

updated by @douglas: 03 Jul 2020 09:16:00AM
hullman56
@hullman56
last year
4 posts
It's not my provider that's the issue, their max size is 1Gb all round, see below, so I should not be having a problem, Genosis sees this as 1Mb

From my PHP panel in Cpanel
post_max_size = 1G
upload_max_filesize = 1G
memory_limit = 1G

Cheers
douglas
@douglas
last year
2,691 posts
The only thing I can think of is that since you have Jamroom installed in a sub-directory, "tree", the 1G settings you see may not cover the "tree" directory. You might check with your hosting provider about that.

Hope this helps!


--

Douglas Hackney
Jamroom Team - Designer/Developer/Support
FAQ-Docs-Help Videos
hullman56
@hullman56
last year
4 posts
Will fire of a message to them and see what they say, hopefully that is the issue

Cheers
hullman56
@hullman56
last year
4 posts
Managed to find the answer in their online knowledge base, it requires the following line in the .htaccess file to activate the php.ini "lsapi_phpini /home/USER/public_html/tree/php.ini", placed this in the .htaccess file in the public_html folder and not the tree sub folder and it appears to be working, as a belt and braces job I did put a new php.ini file in the tree folder with all sizes set to 512m and the system check is reporting 256mb so that's good.

On the system check it is informing me that" jrCore version 6.5.6b1 required (current: 6.5.5)", as I have only just downloaded and installed Genosis should this not have already been up-to-date, and how can I update this.

One more problem happens to have reared it's head, I put in test gedcom with 63 people in it and everything went smoothly, I have tried twice now to install a larger gedcom ( a sub-tree of my main db) 6500+ individuals,and it imports all the ancestors but gets stuck at 3500 Events & Sources so does not install correctly, I fear for my full db of nearly 20,000+ and growing.

Tags