requirewd parameter module is missing??????

soaringeagle
@soaringeagle
one month ago
3,230 posts
so i got this weird error when someone new posted a timeline comment
 {jrCore_module_url} required parameter "module" is missing (modules/jrComment/templates/item_action.tpl)
page where it can be seen
https://www.dreadlockssite.com/nepenthe


--
soaringeagle
head dreadhead at dreadlocks site
glider pilot student and member/volunteer coordinator with freedoms wings international soaring for people with disabilities
soaringeagle
@soaringeagle
one month ago
3,230 posts
i do have 1 modified template, not that 1 however
item_list i have a "comment back' button added and an if user is online condition to show the button


--
soaringeagle
head dreadhead at dreadlocks site
glider pilot student and member/volunteer coordinator with freedoms wings international soaring for people with disabilities
michael
@michael
one month ago
7,050 posts
The url is 404 Not Found.

The error means "you've asked to get the module url for a module, but not said which module you want it for"

What is expected:
{jrCore_module_url module="jrAudio" assign="murl"}
Then {$murl} will be 'audio'.

In your template or template override, for whatever reason the function is turning up like this

{jrCore_module_url module="" assign="murl"}

Since there is no module="" part the function cant return the requested info.

Maybe it was a comment on a module thats now disabled?
soaringeagle
@soaringeagle
one month ago
3,230 posts
i wondered that myself
brand new member whos lil unsure how to use the site and couldn't get an answer how she generated it


--
soaringeagle
head dreadhead at dreadlocks site
glider pilot student and member/volunteer coordinator with freedoms wings international soaring for people with disabilities
soaringeagle
@soaringeagle
one month ago
3,230 posts
weird
ok now i'm getting a totaly diferent symptom
heres what i see now (i should have screenshooted it before too)
that comment that looks like it was posted by her on a @ profile
was a comment i posted on someone elses profile
it wasnt her commenting it was me,
i did reduce my mysql memory footprint a lil and restart mariadb for 1st time in months you think it coulda been a cross referenced data thing from the post being currupted during the db restart? i have no clue
ss11.jpg
ss11.jpg  •  53KB




--
soaringeagle
head dreadhead at dreadlocks site
glider pilot student and member/volunteer coordinator with freedoms wings international soaring for people with disabilities
soaringeagle
@soaringeagle
one month ago
3,230 posts
here is the comment i posted on a diferent profile
it showed up on the other profile, 1st as that error but then, as you saw in the screewnshot, as if posted by her
but here ist is, posted by me on this page
https://www.dreadlockssite.com/zarko-milosavljevic#cm424396
if you click the @ link takes you to index with the #cm424396 attached
so the missing murl module was profile.. that profile
confusing


--
soaringeagle
head dreadhead at dreadlocks site
glider pilot student and member/volunteer coordinator with freedoms wings international soaring for people with disabilities

Tags