solved Unable to initialize modules - verify installation

elke70
@elke70
3 months ago
5 posts
Error: unable to initialize modules - verify installation
after error 524
what should I do, I increased the memory_limit to 512mb and even the time limit to 600 sec and nothing
updated by @elke70: 11 Dec 2020 04:01:27PM
douglas
@douglas
3 months ago
2,679 posts
Hello,

You might check that your server meets the Jamroom requirements here:

https://www.jamroom.net/the-jamroom-network/documentation/getting-started/774/server-requirements

Also, make sure you have the .htaccess file uploaded to your Jaroom root directory.

Also note, Jamroom will not run on a Windows server. If that is still even an option these days.

Hope this helps!


--

Douglas Hackney
Jamroom Team - Designer/Developer/Support
FAQ-Docs-Help Videos
michael
@michael
3 months ago
7,310 posts
That specific error:
Quote: "unable to initialize modules - verify installation"
is only in one location. It occurs when a query to the jr_jrcore_module database table is run and the response contains nothing.

Its expected that that table will be a list of all the modules in the system of which the core module itself should be in the list.

So it suggest that either the install.php script has not been run, which it should have been if all the files are uploaded and the server meets the requirements.... OR that for some reason database table is not there, but can't think why that would be.
elke70
@elke70
3 months ago
5 posts
douglas:
Hello,

You might check that your server meets the Jamroom requirements here:

https://www.jamroom.net/the-jamroom-network/documentation/getting-started/774/server-requirements

Also, make sure you have the .htaccess file uploaded to your Jaroom root directory.

Also note, Jamroom will not run on a Windows server. If that is still even an option these days.

Hope this helps!


Thanks Douglas,
I am running a Linux server
with the suggested requirements but using Ngix instead of Apache ( I used the Ngix file suggested in the installation guide)
thx
elke70
@elke70
3 months ago
5 posts
michael:
That specific error:
Quote: "unable to initialize modules - verify installation"
is only in one location. It occurs when a query to the jr_jrcore_module database table is run and the response contains nothing.

Its expected that that table will be a list of all the modules in the system of which the core module itself should be in the list.

So it suggest that either the install.php script has not been run, which it should have been if all the files are uploaded and the server meets the requirements.... OR that for some reason database table is not there, but can't think why that would be.


Thanks Micheal
I guess you are right...it has to due with the install.php script has not been run correctly or got interrupted! due to response time of the server or due to Gnix server
I ll have to reinstall Jamroom thought
michael
@michael
3 months ago
7,310 posts
Good place to check that's server related is, is 'mod_rewrite' enabled.

The expected flow is that any time any url is hit and the system is not found that mod_rewrite will redirect to the install.php location automatically, so if you're not turning up there automatically, that's my guess.
elke70
@elke70
3 months ago
5 posts
michael:
Good place to check that's server related is, is 'mod_rewrite' enabled.

The expected flow is that any time any url is hit and the system is not found that mod_rewrite will redirect to the install.php location automatically, so if you're not turning up there automatically, that's my guess.

well I am getting a lot of HTTP ERROR 500 and white pages
I guess it has to do with translation of mod_rewrite to nginx (htaccess to nginx configuration instructions.)

Please would you be kind and check from you end?
tecmedia.club
if you need admin access pls let me know
Thx



server
{
listen 80;
listen 443 ssl http2;
listen [::] :443 ssl http2;
listen [::] :80;
server_name tecmedia.club;
index index.php index.html index.htm default.php default.htm default.html;
root /www/wwwroot/tecmedia.club;

#SSL-START SSL related configuration, do NOT delete or modify the next line of commented-out 404 rules
#error_page 404/404.html;
ssl_certificate /www/server/panel/vhost/cert/tecmedia.club/fullchain.pem;
ssl_certificate_key /www/server/panel/vhost/cert/tecmedia.club/privkey.pem;
ssl_protocols TLSv1.1 TLSv1.2 TLSv1.3;
ssl_ciphers EECDH+CHACHA20:EECDH+CHACHA20-draft:EECDH+AES128:RSA+AES128:EECDH+AES256:RSA+AES256:EECDH+3DES:RSA+3DES:!MD5;
ssl_prefer_server_ciphers on;
ssl_session_cache shared:SSL:10m;
ssl_session_timeout 10m;
add_header Strict-Transport-Security "max-age=31536000";
error_page 497 https://$host$request_uri;

#SSL-END

#ERROR-PAGE-START Error page configuration, allowed to be commented, deleted or modified
#error_page 404 /404.html;
#error_page 502 /502.html;
#ERROR-PAGE-END

#PHP-INFO-START PHP reference configuration, allowed to be commented, deleted or modified
include enable-php-73.conf;
#PHP-INFO-END

#REWRITE-START URL rewrite rule reference, any modification will invalidate the rewrite rules set by the panel
include /www/server/panel/vhost/rewrite/tecmedia.club.conf;
#REWRITE-END

# Forbidden files or directories
location ~ ^/(\.user.ini|\.htaccess|\.git|\.svn|\.project|LICENSE|README.md)
{
return 404;
}

# Directory verification related settings for one-click application for SSL certificate
location ~ \.well-known{
allow all;
}

location ~ .*\.(gif|jpg|jpeg|png|bmp|swf)$
{
expires 30d;
error_log /dev/null;
access_log off;
}

location ~ .*\.(js|css)?$
{
expires 12h;
error_log /dev/null;
access_log off;
}
location @rewrite {
rewrite ^(.*)$ /modules/jrCore/router.php?_uri=$1 last;
}

location / {
autoindex on;
index sitemap.xml /modules/jrCore/router.php;
try_files $uri $uri/ @rewrite;
}
location ~ \.php$ {
fastcgi_split_path_info ^(.+\.php)(/.+)$;
fastcgi_pass unix:/var/run/php7.3-fpm.sock;
fastcgi_index index.php;
include fastcgi_params;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
}
access_log /www/wwwlogs/tecmedia.club.log;
error_log /www/wwwlogs/tecmedia.club.error.log;
}
elke70
@elke70
3 months ago
5 posts
Well sorry I just dropped Gnjix I am going for Apache see what happens
michael
@michael
3 months ago
7,310 posts
ah, that would be why the error message reads "apache".

See what's in the error log, should give us a clue.

Tags