PHP 8.1 compatibility for JR and Smarty 4.1.0 Released!

pch
@pch
4 months ago
315 posts
Hi Brian,

As you can see Smarty 4.1.0 has been released with major changes and PHP 8.1 compatibility.

https://github.com/smarty-php/smarty/releases/tag/v4.1.0

In one of your posts, you said that: Currently Jamroom will not work correctly on PHP 8... because a version of Smarty that supports PHP 8 is in the works,

Now that it has been released, any chance to see a JR version compatible with PHP 8.1 anytime soon?

Thanks
updated by @pch: 16 May 2022 07:44:16PM
michael
@michael
4 months ago
7,515 posts
Whats in Php 8 you want to use? Just curious.

Smartys website has this:
Quote: Smarty 4.0.0 is released! This version requires PHP 7.1 or greater. If you need PHP before 7.1 please continue to use Smarty 3.1.4.
which could be an issue. Right now jamroom works on any php above 5.2, if we moved to smarty 4.1 that would require anyone using php 5.2 to also upgrade.

Thanks for the update that Smarty 4.1 was released.
pch
@pch
4 months ago
315 posts
I am not talking about Smarty 4.0.0, but rather Smarty 4.1.0.

Did you get a chance to visit the link below I posted in my previous message?

https://github.com/smarty-php/smarty/releases/tag/v4.1.0

Also, have you read this Brian's post?

https://www.jamroom.net/the-jamroom-network/forum/announcements/64472/php-8-support-for-jamroom

Then, you will probably understand what i mean in this topic. Thanks

Tags