solved Not compatible with PHP version 7.4

alt=
@whodaniel
2 years ago
20 posts
From my web host support: "Hello, Daniel,

I understand your concern regarding website functionality.

I have checked the website https://startree.tv/ and was able to duplicate the reported issue. Currently, PHP version 7.4 is set for your account. It looks like the script you are using is not compatible with PHP version 7.4. This is the reason website is showing error message. It is working fine with PHP version 7.3. You can switch the PHP version to 7.3"
updated by @whodaniel: 12 Mar 2021 09:35:21PM
brian
@brian
2 years ago
10,003 posts
Jamroom works just fine on PHP 7.4 - it's what I actually develop on (7.4.12). You hosting provider will need to make sure the CTYPE functions are enabled in your PHP:

https://www.php.net/manual/en/ctype.installation.php

These are part of the default PHP install, so your hosting provider must have disabled them on purpose.


--
Brian Johnson
Founder and Lead Developer - Jamroom
https://www.jamroom.net

Tags