solved Upgrading to latest Share This module 2.0.0

brian
@brian
3 years ago
10,002 posts
If you have recently updated to the latest Share This module (version 2.0.0), you may have noticed that the Share This section on your detail pages has gone "missing". This is very easy to fix, and is related to the fact that Share This has completely changed the way their system works.

Here's how to upgrade:

1) Upgrade to the Share This beta module
2) Log in to your Share This dashboard: https://platform.sharethis.com
3) On the left of the Share This dashboard you will see the various options that are available for ShareThis
4) Go into EACH option and enable and make the settings as you want
5) Give it 5 - 10 minutes for the ShareThis caching to expire and you'll see the options on your site

Share This is now 100% controlled from the Share This side of things - it is no longer configured or controlled by the module.

IMPORTANT: You must upgrade to the new version to be GPDR compliant!

If anyone has any questions, please let us know.

Thanks!


--
Brian Johnson
Founder and Lead Developer - Jamroom
https://www.jamroom.net

updated by @brian: 04 Sep 2019 10:21:47AM
Zachary Moonshine
Zachary Moonshine
@zachary-moonshine
3 years ago
813 posts
ok i see the link thanks @brian
PatriaCo
PatriaCo
@the-patria-company
3 years ago
349 posts
I am sure glad that you guys are up to speed on all this stuff so that we can just stay focused on our communities. THANKS!!


--
The Patria Company - patriaco.com / quality-trades.com / a-t.life - doing Jamroom since v3
TiG
TiG
@tig
3 years ago
169 posts
One thing that we can control in jamroom is the positioning of the buttons. The new jrShareThis module seems to implement the buttons as a detail feature and thus they show up at the bottom of the content.

Is there a reasonably sound way to position the buttons elsewhere (in our case we would position them below the article and above the comments)? It looks like we would have to somehow stop the feature mechanism for jrShareThis and then manually insert the ShareThis interface code in our templates. (We do not want to change the position of the other detail features.)

As usual, I am looking for advice on how to best accomplish this considering JR design intent.


--
TiG
michael
@michael
3 years ago
7,410 posts
The code to add the inline buttons ( you must activate them at sharethis ) is
 <div class="sharethis-inline-share-buttons" style="margin-bottom: 20px;"></div>
to exclude:
{jrCore_item_detail_features .......... exclude="jrShareThis~sharethis"}
TiG
TiG
@tig
3 years ago
169 posts
Michael

Thanks for the clean method. Will check this out tomorrow (very late here).

Thanks,
TiG


--
TiG
brian
@brian
3 years ago
10,002 posts
If you're just trying to get ShareThis to show above the comments, just go into the Core -> Tools -> Item Detail Features and you can set the order there.

Let me know if that helps.


--
Brian Johnson
Founder and Lead Developer - Jamroom
https://www.jamroom.net
TiG
TiG
@tig
3 years ago
169 posts
Brian

Perfection. Thanks!


--
TiG
ukdenny
@ukdenny
3 years ago
248 posts
I don't seem to be able to make this work now. Do I have to complete the details in the GDPR?
PatriaCo
PatriaCo
@the-patria-company
3 years ago
349 posts
ShareThis has a bunch of cool new tools. I added their script in my meta.tpl to take advantage of them all.


--
The Patria Company - patriaco.com / quality-trades.com / a-t.life - doing Jamroom since v3
brian
@brian
3 years ago
10,002 posts
ukdenny:
I don't seem to be able to make this work now. Do I have to complete the details in the GDPR?

The steps I outlined at the very top should be all you need.


--
Brian Johnson
Founder and Lead Developer - Jamroom
https://www.jamroom.net
brian
@brian
3 years ago
10,002 posts
PatriaCo:
ShareThis has a bunch of cool new tools. I added their script in my meta.tpl to take advantage of them all.

You should not have to modify your meta.tpl file in any way (unless you're doing something custom) - the module will take care of setting it up for you.


--
Brian Johnson
Founder and Lead Developer - Jamroom
https://www.jamroom.net
ukdenny
@ukdenny
3 years ago
248 posts
brian:
The steps I outlined at the very top should be all you need.
I have checked and re-checked and do not know why this is not working.
Do I have to disable the share module?
Do I need to paste this somewhere? Paste the code anywhere you'd like your inline share button to appear.

updated by @ukdenny: 08 Aug 2018 01:17:44AM
douglas
@douglas
3 years ago
2,698 posts
You don't need to paste any code, I believe the module does that for you.

You will need to make sure that your property ID is correct in your ACP > Item Features > ShareThis > Global Config > General Settings. You can get the property ID from your ShareThis settings page.

https://platform.sharethis.com/settings

Hope this helps!


--

Douglas Hackney
Jamroom Team - Designer/Developer/Support
FAQ-Docs-Help Videos
ukdenny
@ukdenny
3 years ago
248 posts
[quote="brian"]
If you have recently updated to the latest Share This module (version 2.0.0), you may have noticed that the Share This section on your detail pages has gone "missing". This is very easy to fix, and is related to the fact that Share This has completely changed the way their system works.

Here's how to upgrade:

1) Upgrade to the Share This beta module
2) Log in to your Share This dashboard: https://platform.sharethis.com
3) On the left of the Share This dashboard you will see the various options that are available for ShareThis
4) Go into EACH option and enable and make the settings as you want
5) Give it 5 - 10 minutes for the ShareThis caching to expire and you'll see the options on your site

Share This is now 100% controlled from the Share This side of things - it is no longer configured or controlled by the module.

IMPORTANT: You must upgrade to the new version to be GPDR compliant!

I carried out all of the above. My property ID is correct, so what else could it be?
michael
@michael
3 years ago
7,410 posts
was it working before the upgrade?
ukdenny
@ukdenny
3 years ago
248 posts
Yes working without issue before upgrade.
michael
@michael
3 years ago
7,410 posts
Then the issue is most likely with your settings on the Share This side of things. Which settings have you chosen?
ukdenny
@ukdenny
3 years ago
248 posts
michael:
Then the issue is most likely with your settings on the Share This side of things. Which settings have you chosen?

Screenshot of JM settings.
updated by @ukdenny: 08 Aug 2018 07:33:18PM
michael
@michael
3 years ago
7,410 posts
At Share This you've chosen to show "Inline share buttons", these show on the 'Detail Pages', so check those check boxes.
inline_buttons.jpg
inline_buttons.jpg  •  54KB

ukdenny
@ukdenny
3 years ago
248 posts
I did that before and just done it again, same issue no display.
What else can I do? I thought I have tried everything.
updated by @ukdenny: 09 Aug 2018 01:06:50PM
michael
@michael
3 years ago
7,410 posts
go back to the beginning and try it all again. Take careful note wherever you need to copy and paste things that there are no spaces around keys. Sometimes when copy+pasting the browser will try to be helpful by adding a capitalization or spaces.

If your key is '123456' and you paste in it with a space or a capitalization that would break things. ' 123456' would fail.
ukdenny
@ukdenny
3 years ago
248 posts
The only space is the one that is on the sharethis platform 'property id.' ID 12345656 and I copied and pasted this exactly as is, checked and double checked.
Is this issue something that you could fix if I paid for VIP Suppport? Because I really am getting frustrated with it now.
michael
@michael
3 years ago
7,410 posts
whats the URL of a page where you expect to see the share this buttons?
michael
@michael
3 years ago
7,410 posts
I can see the buttons on your sites page.

I needed to click the ACCEPT POLICY screen before I could see them though.
buttons_showing.jpg
buttons_showing.jpg  •  135KB

share_this.jpg
share_this.jpg  •  122KB

ukdenny
@ukdenny
3 years ago
248 posts
michael:
whats the URL of a page where you expect to see the share this buttons?

https://justcountry.co.uk/jim-whitman/audio/160/in-annalee
ukdenny
@ukdenny
3 years ago
248 posts
Share This are now looking into this issue for me.
michael
@michael
3 years ago
7,410 posts
The issue is you have a space in your id. Copy the settings from your other site which is working.
issue.jpg
issue.jpg  •  123KB

ukdenny
@ukdenny
3 years ago
248 posts
michael:
The issue is you have a space in your id. Copy the settings from your other site which is working.

I already tried it without the space, just changed it again withouit the space. Same issue. The property id on the platform at Share this has a space so I presumed they had it right?
ukdenny
@ukdenny
3 years ago
248 posts
I have now sorted this issue. It's always a very simple solution to solve a frustrating problem.
The problem WAS with the property id. But not the space. It was because In had copied the id from sharethis and it didn't need 'id' just the number.

Tags