Important TinyMCE upgrade in Jamroom Core 6.4.0

brian
@brian
2 weeks ago
9,881 posts
The newest Jamroom Core 6.4.0 includes an upgrade to TinyMCE 5.0.14 (the "WYSIWYG" editor that Jamroom uses). This NEW release of TinyMCE changes how the editor plugins work, and could show an error in your browser until you full reset your browser caches - especially if you are using Chrome!

Chrome aggressively caches Javascript, which means you are likely to see an error in the editor after upgrading to Jamroom Core 6.4.0. To fix any errors you need to do the following:

1) Make sure any 3rd party Editor plugins (such as the Editor Code Mirror plugin from Ultrajam) are disabled for now until they are updated to support TinyMCE 5+

2) You need to FORCE a full refresh in your browser - unfortunately simply pressing "refresh" in your Chrome browser does NOT do this - you need to do the following:

- If you are using macOS Chrome press Command-Shift-R - this forces a new load that bypasses cache
- If you are on Windows Ctrl-F5 should force a refresh. If you still see an error in the editor, you may need to reset your browser cache completely since this may/may not actually work on some Windows installs.

The upgrade to TinyMCE 5 is an important update since it focuses on improving the mobile editing experience and is needed to address several issues in TinyMCE 4.9 that were not fixed until 5.

If you have any questions please feel free to respond here and we can follow up.

Thanks!


--
Brian Johnson
Founder and Lead Developer - Jamroom
https://www.jamroom.net
Strumelia
Strumelia
@strumelia
2 weeks ago
3,428 posts
I'm noticing something I'd like to fix up in the editor after applying all the latest updates (on my pennywhistle site only).
On my FOTMD site (which has not been updated yet), the tinymce editor window where one types OR edits posts has the default type size of either 12 or 14 (I forget which)... which matches what one sees in the final post.
But on the whistle site after all updates, the editor window when composing or editing a post now has the default text size as 22... which looks jarringly huge. Once you actually publish what you wrote, it appears in the correct site-wide size I chose for discussion posts.

I can't remember where I would go to change this tinymce default setting...? (i seem to recall it was in an admin core or module somewhere, maybe on the server) Or is this an unintended tinymce change that needs correcting for everyone?
Thanks


--
...just another satisfied Jamroom customer.
Migrated from Ning to Jamroom June 2015
Strumelia
Strumelia
@strumelia
2 weeks ago
3,428 posts
ALSO:
I'd like to also note that on the new tinymce editor window, the icons are twice the size that they used to be as well, so the navigation strip they reside on is also twice as tall... AND on my site it now wraps to TWO lines instead of one. The end result is that the icons/buttons strip now takes up four times as much vertical space... which will be a big pain in the butt especially for folks with small screens.
see the following before and after screenshots (from my two different sites, only one of which I've applied all the new updates to):
after.png
after.png  •  188KB

before.png
before.png  •  122KB




--
...just another satisfied Jamroom customer.
Migrated from Ning to Jamroom June 2015
brian
@brian
2 days ago
9,881 posts
Sorry for overlooking your follow up here Strumelia! Unfortunately there is no way at this time to change the icon size in TinyMCE 5 - apparently this is something they are working on, so hopefully it is configurable soon.


--
Brian Johnson
Founder and Lead Developer - Jamroom
https://www.jamroom.net

Tags