Having to log in twice

radiomusicgroup
radiomusicgroup
@charles-brady
5 years ago
107 posts
I have recently noticed that I'm having to log in twice on my sites. Anyone else experience that? When I look at the activity log it shows both log ins. Maybe another chrome browser issue? I looked at several of the member log ins and they all seem to go with one log in but for me it takes two...
updated by @charles-brady: 14 Mar 2016 02:34:52AM
michael
@michael
5 years ago
7,078 posts
I haven't experienced that behaviour.

But some guesses anyhow:
* Are you running both an http and an https version perhaps? or a www and a non-www version independently of each other (weird strange guess i've not seen before, but could possibly exist.)

* any plugins installed in chrome that make it behave differently, like an ad-blocker or other that could be effecting cookies perhaps.
Strumelia
Strumelia
@strumelia
5 years ago
3,477 posts
I'm on Chrome, win7, and I'm not experiencing this issue.


--
...just another satisfied Jamroom customer.
Migrated from Ning to Jamroom June 2015
radiomusicgroup
radiomusicgroup
@charles-brady
5 years ago
107 posts
I'm using Chrome Win 7 as well. It could have been my evernote plugin on Chrome. I removed the plugin and it hasn't happened again so that may have been it.

Another odd thing is that I can't get the login info to save on this site even when the remember me box is checked. That really has me wondering about the cookies.
Strumelia
Strumelia
@strumelia
5 years ago
3,477 posts
You can use "EditThisCookie" chrome plugin to click a green 'lock' icon for your favorite sites so that the cookies will be protected. Do you have Chrome set to automatically clear all cookies after sessions etc? If so then youll still have to log in every time, but if you have your Passwords saved then at least it can auto-fill your info when you have to log in.
I used to have a bit of an issue with my JR site making me log in too often, but that problem seems to have gone away.
Did you check the settings in your User Accounts module?:
user_admin_global.jpg
user_admin_global.jpg  •  215KB




--
...just another satisfied Jamroom customer.
Migrated from Ning to Jamroom June 2015
brian
@brian
5 years ago
9,939 posts
This does seem to be an issue that Chrome users have, and I suspect it is a browser setting like @strumelia suggests - possibly clearing the cookies. JR uses a cookie for the remember me function, so if it is not found it will not work.


--
Brian Johnson
Founder and Lead Developer - Jamroom
https://www.jamroom.net
Strumelia
Strumelia
@strumelia
5 years ago
3,477 posts
I agree it has to do with browsers and perhaps obscure settings and cookie handling...but to tell the truth I had the problem more when I was using Firefox.. ;)


--
...just another satisfied Jamroom customer.
Migrated from Ning to Jamroom June 2015